Server issues with campaign creation
Incident Report for Ambassify
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 13:14 UTC
Investigating
We are currently investigating the problem.
Posted Jun 16, 2022 - 13:07 UTC
This incident affected: Campaigns.