Intermittent slow and failing page loads
Incident Report for Ambassify
Resolved
Platform stability has returned.
Posted Sep 20, 2021 - 09:47 UTC
Investigating
Our hosting provider is currently experiencing issues resulting in failing or slow web requests. We're currently following up the issue attempting to reduce impact.
Posted Sep 20, 2021 - 08:40 UTC
This incident affected: Members, Campaigns, Messages, Reporting, Visuals, Authentication, and Mobile.